最近发现,升级Chrome后访问某些HTTPS站点,Chrome给出明显的红叉警告证书不安全,比如:


 


Chrome官方对此有说明:

主要原因是:
1. SHA1算法已被证明不够健壮,容易受到攻击;
2. Google, Microsoft将在2017年淘汰SHA1算法;
3. 从Chrome 41版本开始,将对SHA1算法的数字证书进行安全告警;
4. 如果SHA1证书有效期到2016年,将出现黄色告警,如果SHA1证书有效期到2017年以后,将出现红色告警;
www.iamadmin.com原创,转载请注明)
解决办法:
1. 证书签发时升级到SHA2算法, 但是还是有不少客户端不支持,比如WindowsXP SP2以下,以及Android 2.2;
2. 证书有效期缩短在2015或2016年内, 等业界推动旧客户端废弃后,再上SHA2;

目前Google, Baidu这些都是控制有效期在2015年, 部分站点直接上了SHA2;
Net | 评论(0) | 引用(0) | 阅读(14611)